d
Topic
Battles Shopify Merchant agmanuals.com
Posts:
25
December 11, 2012

Homepage title= "Please, enter value" This post is outdated

I cannot find where to change the title of my homepage, It currently reads: "Please, enter value". I see where to do this on other pages, but not on the store frontpage of my current theme (Megatronic). Note, I am also not using the "welcome" page as my landing. Maybe I should?

Thanks in advance!

Agmanuals

http://agmanuals.com/

 

AgManuals www.agmanuals.com
i
Replies
lindaS Member
Posts:
37
December 11, 2012

Did you update the name under the General Settings?

Go to Preferences > General Settings > Name of Shop

Battles Shopify Merchant agmanuals.com
Posts:
25
December 11, 2012

Hi Linda,

Thanks for the fast reply.

Currently those are set to-

Shop name: AgManuals

Shop title: Ag Manuals, Welcome

I thought that too, but double-checked I had a value entered and I do.

AgManuals www.agmanuals.com
lindaS Member
Posts:
37
December 11, 2012

You can also update the title code in theme.liquid

Battles Shopify Merchant agmanuals.com
Posts:
25
December 11, 2012

Any advice on where I can change that in theme.liquid?

Excuse my ignorance.

AgManuals www.agmanuals.com
Posts:
489
December 11, 2012

You want to look for the <title> tag in your theme.liquid file. 

The Megatronic theme should already be taking care of <title> tags, did you make any customizations to your shop? Are you using some sort of app?

www.tetchi.ca | www.twitter.com/t3tchi
Battles Shopify Merchant agmanuals.com
Posts:
25
Last edited December 11, 2012

I am using Lexity Live, Plugin SEO (originally thought this was causing it, uninstalled and no change), and Shopify Digital Downloads.

<!-- Meta Tags Editor -->
{% if template contains 'product' %}
	<title>{{ product.metafields.spur_it_metatag.title }}</title>
{% elsif template contains 'blog' %}
	<title>{{ blog.metafields.spur_it_metatag.title }}</title>
{% elsif template contains 'article' %}
	<title>{{ article.metafields.spur_it_metatag.title }}</title>
{% elsif template contains 'collection' %}
	<title>{{ collection.metafields.spur_it_metatag.title }}</title>
{% elsif template contains 'page' %}
	<title>{{ page.metafields.spur_it_metatag.title }}</title>
{% elsif template contains 'index' %}
	<title>{{ shop.metafields.spur_it_metatag.title }}</title>
{% endif %}

Is the above code, where I need to change?

 

 

AgManuals www.agmanuals.com
lindaS Member
Posts:
37
December 11, 2012

Try to change

{% elsif template contains 'index' %}
	<title>{{ shop.metafields.spur_it_metatag.title }}</title>

To

{% elsif template contains 'index' %}
	<title>{{ shop.name }}</title>

Battles Shopify Merchant agmanuals.com
Posts:
25
December 11, 2012

Great Linda, that worked! Thank you so much.

So was it something I did?

AgManuals www.agmanuals.com
lindaS Member
Posts:
37
December 11, 2012

It was looking for the title meta tag on the index file which is why it was showing Please, enter value.  The change that you made will now pull in the Shop name for the title tag on the index file.

Battles Shopify Merchant agmanuals.com
Posts:
25
January 16, 2013

It appears I am also missing:

Meta description

and

Meta keywords

Those are both appearing as "Please, enter value as well!

I have filled out those areas in my theme settings, but still nothing.

AgManuals www.agmanuals.com

Log in or sign up for an account to reply.

This thread has been closed! You will not be able to reply.